I have a developer license and I use it on my desktop PC. On my PC I call GetEngineObject using this license as ProjectID. It works fine.

When I installed a temporary license (a license which is valid for 30 days which you sent me), the function GetEngineObject returns E_FAIL.

The license on the other machine was installed properly - I think. I installed there the LicenseServer and then run LicenseManager and activated this license.

Please help as soon as possible. Thank you.

asked 07 Jan '14, 21:23

ctuser's gravatar image

ctuser
012

Hello,

Could you please post the content of the file %ProgramData%\ABBYY\SDK\11\Licenses\ProductProtection.log. You can delete this file and run your application again before post its content.

Thx.

(08 Jan '14, 16:11) fasar

I sent a zip file to Lara. Here are the relevant lines from the file: 09/01/14 12:26:33 (5232) Application context [0D902D78] created. Identity is user DAVID, computer WINDOWS-2JG8IFP 09/01/14 12:26:33 (5232) Initializing network subsystem 09/01/14 12:26:33 (5232) Server address: , LocalInterprocessCommunication, ABBYY FREngine Windows 11.0 Licensing Service 09/01/14 12:26:33 (5232) Initializing inproc subsystem 09/01/14 12:26:33 (5232) Application context [0D902D78] identity changed. New is user DAVID, computer WINDOWS-2JG8IFP 09/01/14 12:26:33 (5232) Application context [0D902D78] identity changed. New is user DAVID, computer WINDOWS-2JG8IFP 09/01/14 12:26:33 (5232) Exception caught on license SWXE11010003466902040470 run: ERR_PROT_DEVELOPER_LIBRARY_RUN_LIMITATION
09/01/14 12:26:33 (5232) Deinitializing product protection 09/01/14 12:26:33 (5232) Application context [0D902D78] removed

(09 Jan '14, 20:02) ctuser

Two things to do :

  • The first one - Check licences :

Go to LicenceManager et tell us what there is inside (First 4 char,last 4 char., functionality subset, protection type, installation type and expiration date). Check there is no Protection.developper.dll in Abbyy\Bin or Abbyy\Bin64\ dir.

  • Second things to do - If you have access to the code, try to use

    engineLoader = Engine.CreateEngineOutprocLoader();
    engine = engineLoader.GetEngineObject(null);
    licenses = engine.GetAvailableLicenses( [PROJECT ID], null);
    

and do a loop over licences. If you can see a good one, you can use it with :

    engineTmp.SetCurrentLicense(license, false );

I don't know what it is the second param. For me false or true works well (I uses false).

link

answered 10 Jan '14, 15:30

fasar's gravatar image

fasar
625

You are right! I removed the file Protection.developer.dll and the the problem was solved. Thank you!

(12 Jan '14, 13:12) ctuser

Thank you for this! I've been banging my head against this all day!

(22 May '15, 23:30) wraith808

Most probably you are trying to debug your application with the Runtime license which is not allowed.

License SWXE11010003466902040470 is a Runtime one. So with it you can only run your application without Debugging.

link

answered 10 Jan '14, 09:43

Julia%20Anikushina's gravatar image

Julia Anikus... ♦♦
3628

No. There is no development tool in my customer's computer. No debugger.

The problem is not solved.

Any other idea?

(10 Jan '14, 14:11) ctuser
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×23
×1
×1

Asked: 07 Jan '14, 21:23

Seen: 3,194 times

Last updated: 22 May '15, 23:30

© 2016 ABBYY. All rights Reserved. www.ABBYY.com | Privacy Policy | Legal