Hi all,

We try to install FCE on Windows XP SP3 but I receive Unable to load DLL 'FCEngine.dll' error when I start application. The same application works fine on anothes operating sistem: Windows 7 and Windows 8.

I saw in installation guide that there must be some entries in registry, but in my Xp there isn't. I talk about these:

The following registry branches should be accessible from the workstation:
o "HKEY_CURRENT_USER\Software\ABBYY\SDK\9.0\FlexiCapture Engine" — full control o "HKEY_CURRENT_USER\Software\ABBYY\SDK\9.0" — full control for installation only o "HKEY_LOCAL_MACHINE\Software\ABBYY\SDK\9.0" — full control for installation only

I register also FCEngine.dll file with:

C:>regsvr32.exe /c /n /i:"C:\Documents and Settings\All Users\Application Data\ABBYY\SDK\9.0\FlexiCapture Engine\Inc" "C:\Program Files\ABBYY FlexiCapture Engine 9.0\Bin\FREngine.dll"

Still same error.

Can anyone tell me what additional configurations must be made on that OS?

Thx, Dan.

asked 23 Jan '14, 12:32

danm's gravatar image

danm
03


Have you performed developer or runtime installation? Developer installation includes FCEngine.dll registration. Besides you have specified FREngine.dll in the your command line, while it should be FCEngine.dll. One more moment: please check that the path to FCEngine.dll specified in you application is correct. In case none of the mentioned points solve the issue, can you please send the description to the ABBYY support. The contact details can be found from here: http://knowledgebase.ocrsdk.com/article/1397

link

answered 23 Jan '14, 21:35

SDK_support's gravatar image

SDK_support ♦♦
2763

Hi,

I think it's runtime installation. I use: \setup.exe /qb /v PRTYPE=Server ServerName=x.x.x.x

Oh, I think you're right. I made a mistake and I register FREngine.dll instead FCEngine.dll.

I try now to run the same command for FCEngine.dll:

C:>regsvr32.exe /c /n /i:"c:\Documents and Settings\All Users\Application Data\ ABBYY\SDK\9.0\FlexiCapture Engine\Inc" "c:\Program Files\ABBYY FlexiCapture Engine 9.0\Bin\FCEngine.dll"

It seems it's worked. I receive now another error:

System.Runtime.InteropServices.COMException (0x80040112): ERR_FREN_NOTLICENSED.

Thx, Dan

(24 Jan '14, 11:48) danm

Please check that you have specified correct serial number in InitializeEngine object. Since you have made runtime installation, please be sure that you have specified correct ProjectID: developer serial number that matches the necessary license. Please find more details in this Knowledge Base article. Please also be sure that correct Protection Type (file or hardlock)of the used license is specified in FREngine.ini file (located in the /Bin subfolder of FCEngine installation folder), for example: [Protection] ProtectionType=file

(24 Jan '14, 15:45) SDK_support ♦♦

What FCEngine.dll I must register? From Abbyy bin folder installation or from application folder?

Dan.

(24 Jan '14, 15:59) danm

You can use FCEngine.dll from Bin folder

(24 Jan '14, 16:13) SDK_support ♦♦

Hi,

In InitializeEngineObject is correct developer serial. But, if the installation is correct on another operating system as Win7 or Win8, I think not this is the problem.

In my FREngine.ini file from /Bin subfolder I set: [Protection] ProtectionType=server ServerName=x.x.x.x where x.x.x.x is ip adress of machine where NLM is installed. There is license assigned in NLM for my workstation - specified with dns name.

(24 Jan '14, 17:02) danm

Please check that the content of the FREngine.ini file both at workstation and at the machine where NLM installed is the same. In case this approach does not solve the issue, please send the detailed description and the FREngine.ini file to ABBYY support? The contact details can be found from here: http://knowledgebase.ocrsdk.com/article/1397

(24 Jan '14, 17:11) SDK_support ♦♦

Hi,

Content of FREngine.ini file from workstation and server where NLM is installed is the same:

[EngineActivation] Robot=fre-activation-robot@abbyy.com SerialNumber=

[SoapRequest] ActivationServerPage=productactivation.asmx ActivationServerName=activation1.abbyy.ru ActivationServer2Name=activation2.abbyy.ru

[Protection] ProtectionType=Server ServerName=<my_server_name> TCPIPPort=3825 RPCSecurityLevel=None*

I still receive the same error.

Any other ideas??

Thx, Dan.

(25 Jan '14, 18:06) danm

Can you please send the description of your issue to the ABBYY support. The contact details can be found from here: http://knowledgebase.ocrsdk.com/article/1397

(27 Jan '14, 10:57) SDK_support ♦♦
showing 5 of 8 show 3 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×10
×1

Asked: 23 Jan '14, 12:32

Seen: 2,388 times

Last updated: 27 Jan '14, 10:57

© 2016 ABBYY. All rights Reserved. www.ABBYY.com | Privacy Policy | Legal