I'm getting this error when I try to run my compiled program, which uses ABBYY's libraries:

error while loading shared libraries: libFREngine.so: cannot open shared object file: No such file or directory

I've done the following:

echo $LD_LIBRARY_PATH

(looks empty)

Then:

LD_LIBRARY_PATH=/usr/local/lib

And then:

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/ABBYY/FREngine11/Bin

Now echo $LD_LIBRARY_PATH shows the paths I added.

Then I ran export LD_LIBRARY_PATH, and finally sudo ldconfig.

And then I run my app again, and still get the same error.

asked 16 Dec '15, 19:06

Alaa%20M's gravatar image

Alaa M
134


Such error can occur when path to FREngine libraries is not specified. Please double check that libFREngine.so exists on this path: /opt/ABBYY/FREngine11/Bin, then run the following command:

export LD_LIBRARY_PATH = /opt/ABBYY/FREngine11/Bin

In case you use Java, please run also

export JDK = "path to JDK on your machine"
link

answered 17 Dec '15, 11:18

Julia%20Anikushina's gravatar image

Julia Anikus... ♦♦
3628

Thanks it worked!

For some reason though I had to remove the spaces, so this is what I ran exactly:

export LD_LIBRARY_PATH=/opt/ABBYY/FREngine11/Bin
                     ^ ^
(17 Dec '15, 12:06) Alaa M
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Tags:

×1

Asked: 16 Dec '15, 19:06

Seen: 366 times

Last updated: 17 Dec '15, 12:06

Related questions

© 2016 ABBYY. All rights Reserved. www.ABBYY.com | Privacy Policy | Legal