stalled upload

  • 1.1K Views
  • Last Post 27 January 2014
dwery posted this 20 January 2014

I've tried both the curl example and the python example, but the mere uploading of an 1.3MB file stalls until this error is given:

urllib2.URLError: <urlopen error [Errno 104] Connection reset by peer>

Credentials are ok, I made a quick test in python using GetApplicationInfo and it workd correctly.

Also tried with a smaller file with the same result.

Order By: Standard | Newest | Votes
Anastasia Galimova posted this 24 January 2014

Probably the issue occurs due to too slow internet connection.

Anastasia Galimova posted this 24 January 2014

Could you please create a minimum size file and measure how long it takes to process it? The message "Cannot open file" should be returned.

dwery posted this 24 January 2014

I tried with a 180Kb file and our connection is a 100/10 fiber. The upload never ends.

Anastasia Galimova posted this 24 January 2014

Data transfer rate depends on the slowest section in the path, so the developer recommends to create an empty file and test how long it takes to load it.

Also we have a method in beta-testing, which allows to process the images which are located on a remote server. We'll sent you the information about it via e-mail.

dwery posted this 24 January 2014

a 985 bytes file fails. a 783 bytes one works. tell the developer that they have a problem somewhere along the path, probably based on the origin of the packets

Anastasia Galimova posted this 27 January 2014

It looks like you have a network problem on your side. To get the detailed information about it, run our curl sample with the following modifications:

1) change line 86 https://github.com/abbyysdk/ocrsdk.com/blob/master/Bash_cURL/curl_recognize.sh#L86 to

curl -v --user "$ApplicationId:$Password" --form "upload=@$SourceFile" "$ServerUrl/processImage?exportFormat=$OutFormat&language=$Language"

2) remove all the next lines.

Close