Connectivity Issues

  • 1.2K Views
  • Last Post 13 August 2014
Nico posted this 04 August 2014

I'm currently experiencing severe connectivity issues: Sometimes the request times out, sometimes even the hostname cloud.ocrsdk.com cannot be resolved (see [1]). What's more, from time to time the UI (e.g. http://cloud.ocrsdk.com) is also not reachable. All other internet services I consume are running fine so that it does not seem to be related to my personal internet connection. Can you confirm that you're facing network/connectivity problems at the moment?

Thanks, Nico

[1] Caused by: java.net.UnknownHostException: cloud.ocrsdk.com at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:223) at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:431) at java.net.Socket.connect(Socket.java:527) at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:570) at sun.net.NetworkClient.doConnect(NetworkClient.java:158) at sun.net.www.http.HttpClient.openServer(HttpClient.java:424) at sun.net.www.http.HttpClient.openServer(HttpClient.java:538) at sun.net.www.protocol.https.HttpsClient.<init>(HttpsClient.java:276) at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367) at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:172) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:923) at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:158) at sun.net.www.protocol.http.HttpURLConnection.getOutputStream(HttpURLConnection.java:1031) at sun.net.www.protocol.https.HttpsURLConnectionImpl.getOutputStream(HttpsURLConnectionImpl.java:230) […]

Order By: Standard | Newest | Votes
Anastasia Galimova posted this 06 August 2014

We had some problems with ocrsdk.com and forum.ocrsdk.com loading. Yesterday we increased site capacities to avoid it.

Our monitoring does not detect problems with cloud.ocrsdk.com loading. The next time when it will be unavailable from your computer the developer asks to test it availability from your IP: run

nslookup cloud.ocrsdk.com <Local DNS IP>

and from google servers: run

nslookup cloud.ocrsdk.com 8.8.8.8

and let us know about the result.

Nico posted this 06 August 2014

It does not only happen sometimes, but always during a OCR processing roundtrip: Sometimes it fails during picture submission (processImage, see [1]), sometimes it crashes when polling for the result status (getTaskStatus, see [1]), or downloading the result is not working (see [2]).

Here are the outputs of nslookup: $ nslookup cloud.ocrsdk.com Server: 192.168.2.1 Address: 192.168.2.1#53

Non-authoritative answer: cloud.ocrsdk.com canonical name = ocrsdk.cloudapp.net. Name: ocrsdk.cloudapp.net Address: 213.199.129.59

$ nslookup ocrsdk.blob.core.windows.net Server: 192.168.2.1 Address: 192.168.2.1#53

Non-authoritative answer: ocrsdk.blob.core.windows.net canonical name = blob.am2prdstr02a.store.core.windows.net. Name: blob.am2prdstr02a.store.core.windows.net Address: 168.63.0.14


[1] Caused by: java.net.UnknownHostException: cloud.ocrsdk.com

[2] Caused by: java.net.UnknownHostException: ocrsdk.blob.core.windows.net

Nico posted this 07 August 2014

All of a sudden, without having changed anything on my side, it's working again. I have no clue what the reason might have been: It worked for months, stopped working in the last few days, and as of now it's up and running again.

Anastasia Galimova posted this 13 August 2014

We are happy to know that the issue is solved. Please let us know if it occurs again.

Close