Error while loading shared libraries: libFREngine.so

  • 387 Views
  • Last Post 17 December 2015
  • Topic Is Solved
Alaa M posted this 16 December 2015

I'm getting this error when I try to run my compiled program, which uses ABBYY's libraries:

error while loading shared libraries: libFREngine.so: cannot open shared object file: No such file or directory

I've done the following:

echo $LD_LIBRARY_PATH

(looks empty)

Then:

LD_LIBRARY_PATH=/usr/local/lib

And then:

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/ABBYY/FREngine11/Bin

Now echo $LD_LIBRARY_PATH shows the paths I added.

Then I ran export LD_LIBRARY_PATH, and finally sudo ldconfig.

And then I run my app again, and still get the same error.

Order By: Standard | Newest | Votes
Julia Anikushina posted this 17 December 2015

Such error can occur when path to FREngine libraries is not specified. Please double check that libFREngine.so exists on this path: /opt/ABBYY/FREngine11/Bin, then run the following command:

export LD_LIBRARY_PATH = /opt/ABBYY/FREngine11/Bin

In case you use Java, please run also

export JDK = "path to JDK on your machine"

  • Liked by
  • Alaa M
Alaa M posted this 17 December 2015

Thanks it worked!

For some reason though I had to remove the spaces, so this is what I ran exactly:

export LD_LIBRARY_PATH=/opt/ABBYY/FREngine11/Bin
                     ^ ^

Close