• Last Post 25 February 2016
ericp posted this 22 February 2016

Starting on Friday February 19th our application started having intermittent errors accessing the cloud ocrsdk api. However, it is erroring out each time with what looks like an SSL error. Our application is an Ionic Hybrid application which throws the following error in the Xcode console: NSURLSession/NSURLConnection HTTP load failed (kCFStreamErrorDomainSSL, -9813). I can access the ocrsdk api fine when I drop to http, but that is not acceptable for our application. Also, from both an iOS device and an Android device if I go to the I get network errors. I have attached screenshots for error ios error

Order By: Standard | Newest | Votes
ericp posted this 22 February 2016

I have done further testing with mobile browsers accessing on both ios 9.2 and ios 9.2.1. I can reproduce the certificate problem on ios 9.2.1 using both chrome and safari. Chrome errors out and Safari says it cannot verify server identity. Also, the hybrid Ionic app on ios 9.2.1 will work intermittently which might mean you have some servers with the wrong certificate.

Dan Jacobs posted this 22 February 2016

We're finding problems with the certificates that Abbyy use because they're provided by an ... exotic issuer.

Our issue is that we use Heroku who don't support their certificate and don't allow you to manually add the certificate as we don't have access to the file system.

For $300 Abbyy could buy a fully supported and recognised certificate that would solve a lot of these problems.

ericpres posted this 22 February 2016

Any feedback from the ABBYY team. Our application is failing as users are rapidly upgrading to iOS 9.2.1. Please provide some feedback.

ericpres posted this 23 February 2016

I checked the certificate at Symantec and it gives an error for cert not installed correctly

Oksana Serdyuk posted this 24 February 2016

Dear all,

We are extremely sorry for the delay in our response due to the state holidays in Russia. Indeed, for some reasons an intermediate certificate in a chain becomes invalid from time to time during last few days. We did not update the certificate and did no changes in the service, so we could not affect the validity of the certificate. Our IT and R&D departments are in contact with MS (service host) and GoDaddy (the certificate issuer) to find the cause. As soon as we get some new information, we will let you know.

Oksana Serdyuk posted this 25 February 2016

The update of the request:

Yesterday our development team made some changes on our side concerning SSL. An intermediate certificate was installed in addition to the main one on IIS8 used in the service. Also the service was re-deployed on the earlier version of the operating system. The fact is that the newer version has two changes regarding SSL, and we suppose that these changes might have this effect. Moreover the issue did not manifest itself immediately after changing the image of the operating system, it could begin gradually to occur on one user's side till the effect became quite significant.

Please kindly make sure that the issue is already solved on youк side and it has not been reproduced anymore?

Please take our apologies for possible difficulties to your business caused by this issue and thank you for your patience and collaboration!

ericpres posted this 25 February 2016

I have tested my application and customers are using it without issue now. We will keep a close eye on it and let you know if the issue resurfaces. Thank you.

Oksana Serdyuk posted this 04 March 2016

Dear ABBYY users,

Our development team did their best for localization and resolution of the issue. But this case is indeed very special, as only a few customers faced with the issue, and the service actually worked fine and other customers did not have problems. Moreover our own tests did not reveal the problem either, and the service certificate was valid. So, in order to thoroughly validate our resolution we would like to ask you to take part in our testing. For this it is necessary just use our test service which modulates the problem configuration. We would be very grateful if you are able to reproduce the issue again and inform us about it.