Inconsistent response from the API

  • 1.2K Views
  • Last Post 21 July 2016
anjesh posted this 19 July 2016

It's been several days the Abbyy API response have been having some issues. Our transcriptions process has stopped and keep waiting for the response from the Abbyy. The same response comes through when tried again. We couldn't easily pinpoint the exact error. We used strace and tcpdump to trace the issue. In one instance, the script stopped at one instance and it worked in the second attempt. Can you see if that's the issue at your end. I have attached the screenshots as well.

On the first attempt, the response stuck at the following and the script also got stuck waiting for the complete response. alt text

And for the same page, on our second attempt, we get the full response and the script moved to the next page

alt text

Order By: Standard | Newest | Votes
Oksana Serdyuk posted this 19 July 2016

Could you kindly specify your Application ID and provide us with the logs from the Fiddler HTTP debugger (you can download it from www.fiddler2.com)?

Vitalie posted this 20 July 2016

The last 5-6 days we too have the problem of API response. I have tested 20 files, and for 3 of them we have not received API response with the result link... The connection was closed. This is very strange, because we have not made any modification to our service.

anjesh posted this 20 July 2016

my app id: resource-contracts

I captured the packets using tcpdump in the server and viewed in wireshark. The responses are inconsistent. For the same file, on first attempt, the script stopped at page 14

alt text

And in second attempt, the script stopped at page 2 for the same file. alt text

TCP packets are different in 2 cases - that is the last packet that came through and then nothing's coming afterwards. This occurred only during /getResult?taskId API call only. I hope this helps. I can't share the cap file as it contains the credentials.

Attached Files

Oksana Serdyuk posted this 21 July 2016

Thank you for the description of the issue. Could you please send the Wireshark logs to CloudOCRSDK@abbyy.com?

Oksana Serdyuk posted this 21 July 2016

Thank you for the logs. The developers recommend you:

•not to use the undocumented getResult method,

•if there is some timeout, retry the request after some time.

Close