"Unclosed root tag" and "Non-whitespace before first tag"

  • 1K Views
  • Last Post 29 September 2016
evgeny posted this 20 September 2016

Hi, i'm trying to read phone screenshots in hebrew and many files, sometimes 9 out of 10, return these 2 subsequent errors from the "processingCompleted" function: 1. Unclosed root tag Line: 0 Column: 269 Char: 2. Non-whitespace before first tag Line: 0 Column: 1 Char: /

Can you tell me what's wrong? is anything i can do about it?

Attached are two example files.Thank you

Evgeny

alt text alt text

Attached Files

Order By: Standard | Newest | Votes
evgeny posted this 22 September 2016

Hi, is there any news?

Please help!

Evgeny

Oksana Serdyuk posted this 22 September 2016

Hi Evgeny,

In general, your application logs are fine on our side: all recognition tasks are processed successfully. It seems that these issues are connected with your development environment, because the messages are not returned by our service. First of all, please try to check the following reference in the Internet: Non-whitespace before first tag

And if you still need our help, please send to CloudOCRSDK@abbyy.com the logs from the Fiddler debugger or any of its analogue that supports your device. The logs should include the headers, the request content and the response from the service. We will show them to our developers for clarification of the issue.

evgeny posted this 22 September 2016

Hi, Oksana. This is what i saw: for some files after i get the taskid i get a response that looks like this:

"Task id = 38ccc6b8-102e-411c-8f5a-71c4cf88ef1d, status is Queued bad data <?xml version="1.0" encoding="utf-8"?><response><task id="38ccc6b8-102e-411c-8f5a-71c4cf88ef1d" registrationTime="2016-09-22T15:46:51Z" statusChangeTime="2016-09-22T15:46:52Z" status="Completed" filesCount="1" credits="0" resultUrl="https://ocrsdk.blob.core.windows.net"

the resultUrl is not full - ends with ".windows.net" and then i get the XML parsing error : Non-whitespace before first tag.

Please help

evgeny posted this 22 September 2016

another example:

"<?xml version="1.0" encoding="utf-8"?><response><task id="2e13f9dd-e9f9-43fd-9b09-ba7feb1846bf" registrationTime="2016-09-22T15:52:53Z" statusChangeTime="2016-09-22T15:52:53Z" status="Completed" filesCount="1" credits="0" resultUrl="https://ocrsdk.blob.core.windows.net"

thank you

Evgeny

Oksana Serdyuk posted this 23 September 2016

Could you please specify what device and development environment you use?

evgeny posted this 26 September 2016

Hi Oksana.

I work with node js in MS studio.

Evgeny

evgeny posted this 28 September 2016

Hi Oksana, is there any news?

Evgeny

Lilya Chesnova posted this 29 September 2016

Hi Evgeny,

The code used to generate the answer - the same for all customers. And we haven't got the similar issues from other customers. Our developers supposed that a part of XML could be lost at the network layer during data transmission. Information on the tasks that you pointed to has already been automatically deleted by our cleaning procedure. Please check if this issue could be connected with some network problems on your side? And send us the task ID right after the issues occurs next time - we will check the result of this task we are getting on our side.

Lilya

Close