Error uploading a pdf with ocrsdk

  • Last Post 26 October 2013
ricardoaandres posted this 25 October 2013

I need to upload a pdf file with text to the OCR and download a .docx file using a ruby app I've developed. The code is OK, but I always receive a "WARN: Error: Unsupported image file format". It is a PDF file that only contains text. (I also tried with pdf with an image.) I'm trying with processImage method.

I really need this feature to work as soon as possible.

i'm using a pdf 1.3 file.

Order By: Standard | Newest | Votes
Anastasia Galimova posted this 25 October 2013

This error may occur if you are trying to process the image which is located on a remote server. The processImage method is not suitable for this task. You should use a method, which is in beta-testing now, we can send you information about it via e-mail.

If you process the image which is located on your computer, please try to process this image with our sample code and let us know about the result.

  • Liked by
  • ricardoaandres
ricardoaandres posted this 25 October 2013

Anastasia, I tried downloading the file from S3 to my computer and then send it to the OCR, so I think it's the same as working with local files. Please correct me if I'm wrong.

I'd love to receive some information about the method you mentioned.

Anastasia Galimova posted this 26 October 2013

I've send you the information about the method via e-mail.

Could you please clarify if the issue could be reproduced with our sample code If yes, please share or send to the file you recognize.