[Unix] java.lang.UnsatisfiedLinkError: Can't open shared object file

  • 1.9K Views
  • Last Post 07 October 2015
  • Topic Is Solved
LorisBachert posted this 01 October 2015

Hello everyone,

i already saw there are two other posts about an UnsatisfiedLinkError, but none of them solved my problem. I'm developing an java application running on a Redhat server. If i initialize the FREngine i'm getting the following error:

Exception in thread "Thread-1" java.lang.UnsatisfiedLinkError: /opt/ABBYY/FREngine11/Bin/libFREngine.Jni.so: libFineObj.so: Cannot open the shared object file: file or directory not found

I don't understand why the file can't be found because if i watch my filesystem the file is existent.

If you need any more information just ask for it :)

Thanks in advance, Loris Bachert

Order By: Standard | Newest | Votes
Julia Anikushina posted this 06 October 2015

Such error message could appear when path to FREngine libraries or to JDK is not specified. To avoid the appearance of this message, please, run the following commands before building and running your application:

EXPORT LD_LIBRARY_PATH=<FREngine_Install_Dir>/Bin
EXPORT JDK=<path to JDK on your machine>

  • Liked by
  • LorisBachert
LorisBachert posted this 07 October 2015

This solved my problem. Thanks a lot :)

Close