Problem with engine initialization in Unix

  • Last Post 07 October 2015
LorisBachert posted this 06 October 2015

Hello everyone,

i got a problem regarding the initialization of the ABBYY FineReader Engine in Java. I created a java application which should extract text of pdf files. I found an example code which initializes the engine like that:

engine = Engine.GetEngineObject(AbbyyConfig.GetDllFolder(), AbbyyConfig.GetDeveloperSN());

If i run my application on windows everything works like a charm but if i run my application on unix (of course with other paths for the installation) the GetEngineObject call does nothing but suspend my application. Can anyone of you provide some help regarding this issue?

Thanks in advance, Loris

Order By: Standard | Newest | Votes
Julia Anikushina posted this 07 October 2015

Could you please specify whether you use different FRE distribution kits and licenses for Linux and Windows?

LorisBachert posted this 07 October 2015

Your question brought me to the solution!!! Thanks a lot

LorisBachert posted this 07 October 2015

I solved my problem. For everyone who has the same issues:

The problem is that the jar file for windows and for unix are different. So you can't develop for both OS in the same project.