Cordova clean project Java compilation fails

  • 47 Views
  • Last Post 4 weeks ago
  • Topic Is Solved
John_Doe85 posted this 4 weeks ago

I have installed ABBYY's Cordova plugin several times, but I keep getting an error while doing the compilation.
There is a missing MultiPageImageCaptureScenario component while compiling the Java sources (there are 23 errors like this) :

F:\Projects\myApp\platforms\android\app\src\main\java\com\abbyy\mobile\rtr\cordova\activities\ImageCaptureActivity.java:26: error: cannot find symbol

import com.abbyy.mobile.uicomponents.scenario.MultiPageImageCaptureScenario;

                                             ^

  symbol:   class MultiPageImageCaptureScenario

  location: package com.abbyy.mobile.uicomponents.scenario

Here's the exact procedure I followed :

  • ionic start myApp blank--cordova
  • ionic cordova platform add android
  • ionic cordova plugin add cordova-plugin-abbyy-rtr-sdk
  • Copy abbyy-rtr-sdk-1.0.aar and abbyy-ui-1.0.aar in a new libs\android folder. 
  • Add .license in new platforms\android\platform_www\rtr_assets folder.
  • Change minSdkVersion in config.xml from 19 to 21.
  • ionic cordova build android

Here's the output of ionic info : 

Ionic:

   Ionic CLI          : 5.4.15

   Ionic Framework    : ionic-angular 3.9.9

   @ionic/app-scripts : 3.2.4

Cordova:

   Cordova CLI       : 9.0.0 (cordova-lib@9.0.1)

   Cordova Platforms : android 8.1.0

   Cordova Plugins   : cordova-plugin-ionic-keyboard 2.2.0, cordova-plugin-ionic-webview 4.1.3, (and 5 other plugins)

Utility:

   cordova-res : 0.8.1

   native-run  : 0.3.0

System:

   Android SDK Tools : 26.1.1 (F:\Logiciels\Android_SDK)

   NodeJS            : v12.14.1 (C:\Program Files\nodejs\node.exe)

   npm               : 6.13.4

   OS                : Windows 10

I tried using different JDK 8 versions (jdk1.8.0_241 and jdk1.8.0_211). I have Gradle and all android SDKs from 19 to 28. I tried with a blank Cordova project (without ionic), exact same result. 

Does anybody know how a clean project can throw this error? Thanks.

John_Doe85 posted this 4 weeks ago

 After trying different configurations during hours, I finally found that the file MultiPageImageCaptureScenario is missing from the folder scenario inside classes.jar in abby-ui-1.0.aar file.

The solution is to download the previous release (release 5) of the package and take its abby-ui-1.0.aar file...

Close