Differences occur in pixel values

  • Last Post 2 weeks ago
lx11020219 posted this 3 weeks ago

It is an additional question about the coordinate unit.

Coordinates are answers with pixels, but the values do not match.

When recognizing the attached image file, the following values (some excerpts) can be taken.


# Page, X, Y, Width, Height, Text, FontName, FontSize, RGB (R), RGB (G), RGB (B), Spacing, Bold, Italic, StartWord, Suspicious

1, 35, 38, 20, 22, A, MS PMincho, 11, 0, 0, 0, 0, False, False, True, False

1,56,38,19,22, B, MS PMincho, 11,0,0,0,0, False, False, False, False

1,79,38,19,23, C, MS PMincho, 11,0,0,0,0, False, False, False, False

1,99,38,37,23, MS PMincho, 11,0,0,0,0, False, False, False, False


However, it is different from the pixel value on the image.

Why does this difference occur?


Please change the extension from .pdf to .tif.

Attached Files

Order By: Standard | Newest | Votes
Denis Gusak posted this 2 weeks ago


Can you please provide some screenshots? I checked the coordinates of the letters on your image and they coincided with those that FineReader Engine returns.

Catherine Arkhipova posted this 2 weeks ago




I tried to reproduce your issue too.

Result is the same: there is no difference between coordinates received via API and Paint.


First, I accessed to first line symbols’ positions via CharParams object properties. Here is the result: 


Then I checked coordinates on the initial image via Paint: (WrExt2.png) Coordinates coincide. (And also match the ones you provided above)



Could you provide us with more information about your issue? How did you get right coordinates?