GetEngineObject fails with The time allowed for licensing servers synchronization has expired

  • Last Post 05 January 2018
  • Topic Is Solved
Christian Clausner posted this 05 January 2018


When trying to use a FRE11 network runtime license the GetEngineObject fails with:

"Failed to run license SWER-xxxx-xxxx-xxxx-xxxx-xxxx. The time allowed for licensing servers synchronization has expired."

I can see the license in the License Manager. I also tried to edit the license settings XML to (adding LicensingServers):

<LicensingSettings xmlns="">
  <ConnectionProtocol ProtocolType="LocalInterprocessCommunication"/>
  <EnableCodeMeterLicenses Enable="No"/>
  <EnableIKeyLicenses Enable="No"/>
  <MainNetworkLicenseServer ServerAddress="" ProtocolType="TCP/IP" EndPointName="3011">

Any idea what I'm doing wrong?


Denis Gusak posted this 05 January 2018


This issue occurs if the license is intended to be used with a redundant licensing server but the file LicensingSetting.xml is not configured for this.
Please check [Help → Licensing → About the LicensingSettings.xml File] “Setting up a redundant license server configuration” section for more information.

If you are not going to use a redundant licensing server please contact the manager who issued your current license to disable this function.


  • Liked by
  • Christian Clausner