Initializing Engine... Unknown COM error: 80004005

  • Last Post 14 December 2018
Surendra M posted this 22 November 2018

Hi ,

Getting below error when running FreEngine on Linux 16.04


root@189d082e32be:/opt/ABBYY/FREngine12/Samples/Java/Hello# ./

Initializing Engine...

Unknown COM error: 80004005


Order By: Standard | Newest | Votes
Anthony Hartshorn posted this 10 December 2018

I'm getting the same issue. Was there any resolution?

erion posted this 10 December 2018

The same issue here using Java. Interestingly, the C++ samples run fine, and as soon as they do, the Java samples start working as well. I'm not sure what the cause is.

Nadezhda A. Solovyeva posted this 11 December 2018

The reason for your issue is either FineReader Engine or Java incorrect configuration.

Please try running C++ "Hello" sample to check, if FineReader Engine is configured correctly. If you will receive an error message, then please send it to us.

erion posted this 11 December 2018

1. Running FRE Hello Java sample: Failed.


2. Running Hello C++ sample: worked.


3. Running Hello Java sample: worked.


OP's issue might be different, but this has fixed it for me. Not sure what the C++ code does that fixes the Java one.

erwin.flores posted this 12 December 2018

I had this issue when testing FREngine in a docker container. I performed the "ldd" command on the library files in the "Bin" folder to look for missing dependencies and found that there was a missing dependency: libgomp1. Installing this library allowed me to bypass this problem, but this may vary between installation configurations.

I also performed the steps of:

1. Testing the java sample: failed

2. Testing the C++ sample: worked

3. Testing the java sample: worked

Between steps 1 and 2 I had to install g++ and make, so I presumed that the missing dependency was installed when installing g++.

erion posted this 14 December 2018

Thanks, this is quite helpful.


As far as I am aware, libgomp1 is an OpenMP implementation, and it might just be the solution as you are right, it did get installed with G++ on our test machine as well.


From the System requirements chapter in the documentation:


For the FineReader Engine dynamic library the standard, and libraries have to be used.


Unfortunately, package names are not mentioned. Thanks again, @erwin.flores.