OCR License Issue

  • 82 Views
  • Last Post 1 weeks ago
  • Topic Is Solved
dheena raj posted this 2 weeks ago

 Hi..i have used Abby RTRSDK for text capture.It was working in sample app.When i implement on my project ,its showing like "AbbyyRTRSDk : No license file". Please help to sort out this issue.What should i do to overcome this issue?

Order By: Standard | Newest | Votes
Oksana Serdyuk posted this 2 weeks ago

Please make sure that you have added the license file to your project: the valid license should be copied inside the assets directory inside the project structure (for example, as for our sample the directory is sample-textcapture\app\src\main\assets).

Also kindly check that you have specified the correct name of the license file in the code. It must be exactly the same name, because in a LINUX-derived OS capitalization in file names matters.

dheena raj posted this 2 weeks ago

Hi i have tried what you said. but still no change.Herewith i have mentioned screenshot of project Architecture and logs.

This logs printed from sample project downloaded :

 

This logs printed from that copied sample project and pasted in desktop :

licensePath::::/Users/ganesh/Library/Developer/CoreSimulator/Devices/98FBCFFF-3471-4AA3-ADFE-640E7200379D/data/Containers/Bundle/Application/4CA63915-BF3C-458C-9FEE-493384E08386/TextCapture.app/AbbyyRtrSdk.license

2017-10-09 09:05:09.538973+0530 TextCapture[96219:9010093] ABBYY RTR SDK: No license data.

 

My project structure

Kindly check this and let me know where i did mistake.Thanks in advance.

Oksana Serdyuk posted this 2 weeks ago

Please try to move the license file from the License folder to the assets folder.

  • Liked by
  • dheena raj
dheena raj posted this 2 weeks ago

Thanks. Now i am getting license data length. But another problem occurs. OCR not recognising texts. Its showing error "Invalid recognition language settings. Language is not selected". I have tried that Go to the section "Build Phases" and create "New Copy File Phase", select destination - "Resources" and subpath - "Dictionaries", add the dictionary file to the list. 

dheena raj posted this 2 weeks ago

Hi Oksana Serdyuk, Kindly help me to solve this issue. i am stuck in this issue since last two days

Oksana Serdyuk posted this 2 weeks ago

Have you set a specific recognition language using the setRecognitionLanguages method in your project before OCR? Please see how it is done in our standard sample in RTRViewController.swift.

What recognition language do you try to use? Please be aware that not all languages are available for the free version of RTR SDK. Also please make sure that the corresponding .edс file exists in the ...\assets\dictionaries folder if you use the recognition language with the dictionary support (see Available OCR Languages for more details).

If the issue persists, please share your project to let us investigate it on our side.

dheena raj posted this 2 weeks ago

i have set language "ENGLISH" only and also those file is present in  \assets\dictionaries folder..Still issue occurs. How can i share my sample code to you?

dheena raj posted this 2 weeks ago

Please find the below dropbox URL of my sample project code. Kindly check once

Project Link : https://www.dropbox.com/s/jv0xb7l1235qiec/Finder.zip?dl=0

dheena raj posted this 2 weeks ago

 I have uploaded in Abbyy share.Kindly check now

dheena raj posted this 1 weeks ago

I have downloaded sample project and implemented as what you said in video tutorial. i am getting Invalid language settings error and invalid settings error.there is no path for (patterns/FindText.tom)..What should i do overcome this issue?

Oksana Serdyuk posted this 1 weeks ago

Thank you for the provided information. Unfortunately, currently we do not have enough resources to provide you with a quick solution.

Therefore, we would recommend you to follow the chain of creation of your project from our standard sample to your own project once again. As you wrote in your first post, our standard sample was working fine. Could you please try to begin your development strictly following our documentation and instruction how to build sample application for RTR SDK?

Also please specify why you added the line in your code:

guard let path = Bundle.main.url(forResource:"FindText", withExtension: "rom") ...

In our samples, all dictionaries and patterns are loaded from the corresponding folders of the assets folder. You do not need to open them separately. Your final project should also contain the libs and assets folders and this structure is necessary for the final distribution of your application.

dheena raj posted this 1 weeks ago

I have tried to print path of FindText file.i am getting path. But getting error " Invalid settings. There is no data at path: <Patterns/FindText.rom>."  I have followed instruction from article. No  change in result.

Close